Table of Contents

Tabular Editor 3.18.1

Important

Tabular Editor 已推出更新版本。你可以在这里查看最新版本。

Tabular Editor 3.18.1 .NET 8 下载:

Tabular Editor 3.18.1 .NET 6 下载:

如果你此前从未使用过 Tabular Editor 3,则可获得 30 天试用期,安装后即可激活。你也可以在此purchase a license.

Important

.NET 6 将于 2024 年十一月起停止支持。如果您目前无法安装.NET 8 桌面运行时,请联系贵组织的 IT 部门提前规划,因为在 2024 年十二月之后,我们将不再提供 Tabular Editor 3 的 .NET 6 版本构建。或者,你也可以使用我们的便携版,其中已包含所需的 .NET 运行时。

3.18.1 改进内容

  • 当使用表名作为变量名时,语义分析器将不再显示错误。**注意:**截至本文撰写时,Power BI Desktop(2024 年十月版)和 Power BI Service 已支持使用表名作为变量。你可以在 工具 > 偏好 > DAX编辑器 > DAX 设置 > 表名变量 下控制错误处理行为。
  • 我们已将 AMO/TOM 客户端库更新到最新版本 19.86.6。这应能修复部分用户在连接 Power BI XMLA endpoint 时遇到的 Can't obtain account information for '(e-mail)' while trying to refresh the token. 问题,详见 #1387。
  • 在 工具 > 偏好 > Power BI 中新增了一个选项,可指定连接到 Power BI / Fabric Workspace 或 Azure Analysis Services 时默认使用的身份验证模式。例如,你可以将 Microsoft Entra MFA 设置为默认值,从而在连接时强制弹出帐户选择器/MFA 窗口。
  • 对于多用户许可证,如果已超出许可证的用户数上限,我们现在会显示一个用于更改许可证密钥的选项。这样一来,你就不必再手动通过 Windows 注册表 重置许可证密钥。

3.18.1 错误修复

  • 当尝试使用尚未完全设置的 Tabular Tools 账号连接到 DAX优化器服务时,我们现在会显示更清晰的错误信息,而不是抛出未处理的异常。
  • 修复了一个 Bug:在 Tabular Editor 3 中创建的 VPAX 文件在 DAX优化器服务中打开时,会被提示已损坏。
  • 修复了一个 Bug:如果在上传过程中收集 VPAX 统计信息失败,会向 DAX优化器服务上传一个空的 VPAX 文件。
  • 修复了一个 Bug:打开新模型时,表达式编辑器 的语义引擎功能并非总会更新(可能导致编辑器中出现误报错误)。
  • 语义分析器在包含复杂、嵌套 DAX 表达式的模型中,不应再引发“An item with the same key has already been added.”异常,详见 #1390 和 #1393。
  • 语义分析器现在可以正确推断 SELECTEDVALUE('MyTable'[String Column], BLANK()) 这类表达式的数据类型(此例中,结果数据类型应为 String,但此前会被推断为 Variant)。
  • 修复了一个问题:简化变量 代码操作会生成与原始代码在语义上不等价的代码。此外,该操作不再会导致代码操作被“循环”应用,参见 #1386。

3.18.0 新功能

查看我们的 发布博客,快速了解本次发布中最重要的更新。

  • 我们的 DAX优化器集成 现已结束预览;同时我们也做了一些更新,使其支持 DAX优化器 1.2 中新增的评估指标。对了,顺便一提——所有 企业版 Tabular Editor 3 用户现在每天都可以免费运行 DAX优化器 4 次。从上方任一链接下载 Tabular Editor 3.18.0,并通过 帮助 > 关于 Tabular Editor 菜单项获取你的 DAX优化器兑换码。
  • 我们很高兴在 Tabular Editor 3 的所有 DAX编辑器中推出一项新功能:代码操作。这个提升效率的功能会在不打扰你的情况下,为改进 DAX 代码提供建议,并让你一键应用这些建议。例如,此功能可用于删除未使用的变量、遵循列和度量值引用的最佳做法、将表筛选重写为更高效的列筛选,以及更多更多内容。我们计划在后续版本中加入更多操作,所以继续关注吧!
  • 在我们升级到 Microsoft AMO/TOM 客户端库的最新版本 后,集成身份验证选项的行为发生了变化:如果 Windows 操作系统已连接到某个 Entra ID 帐户,就不会再显示 Entra ID 帐户选择器/MFA 弹窗。因此,我们新增了一个身份验证选项:Microsoft Entra MFA。它会强制弹出帐户选择器/MFA 弹出窗口,以便你在需要时选择不同于当前登录 Windows 的帐户的其他帐户。

3.18.0 中的改进

  • 我们扩展了用户界面偏好设置:现在可以在标题栏中隐藏模型源的详细信息,帮助在录屏和演示时保护敏感信息。
  • 用户界面偏好现在新增了一个“最近使用的项目”部分。你可以在此部分中自定义文件菜单中显示的最近文件和模型数量,以及“最近连接”中显示的服务器数量。新的偏好还允许清除这些项目。
  • 如果将变量直接用作 CALCULATE 或 CALCULATETABLE 的第一个参数,语义分析器现在会显示警告。由于变量不受语境转换或更改后的筛选语境影响,因此以这种方式使用变量很可能是无意的。
  • 我们的 SQL 编辑器现在采用了改进的配色方案,更容易区分 SQL 关键字和标识符。
  • 将 AMO/TOM 及其他依赖项升级到最新版本。
  • 现在,对于新的 Power BI / Fabric 语义模型,我们使用兼容级别 1606。在该级别下,新增了模型属性 ValueFilterBehavior,可用于控制 SUMMARIZECOLUMNS 的 auto-exist 行为。
  • 我们新增了对 TOM ChangedProperties 集合的支持(适用于表、度量值、列及其他一些对象)。此集合用于复合模型或 Direct Lake 模型,用于指示某个属性(例如列 Name)已更改,因此不应再从底层数据源同步。
  • 将 VertiPaq分析器升级到最新版本 (1.7.2),修复了在包含字段参数 / 分组列的模型中提取统计信息时出现的问题。
  • 将我们使用的 Snowflake .NET 连接器升级到 v4.1.0。这修复了以下漏洞:CVE-2023-34230 和 CVE-2023-51662。
  • 在处理包含大量关系的大型图表时,图表组件现在应该快得多。
  • 在数据预览中,现在可以右键单击列标题并选择“隐藏此列”来隐藏列。若要显示隐藏列,请右键单击列标题并选择“列选择器”。这将打开一个窗口,你可以在其中查看之前隐藏的列。

3.18.0 中的错误修复

  • 修复了 从数据库加载语义模型 对话框中“服务器”下拉列表不显示最近使用的服务器的问题。
  • 数据预览设置(排序方式、筛选器等)这些设置现在会在刷新预览后保留,修复了此前刷新后设置无法保留的 bug。
  • 修复了在 DAX编辑器中使用“重命名”重构期间或刚完成后执行撤销(Ctrl+Z)可能导致的崩溃。
  • 当显示“请稍候”对话框时(例如执行表架构更新时),主 UI 现会正确锁定,避免用户继续操作。
  • 在 DAX 表达式中引用内部“FormatString”度量值时,语义分析器不再显示警告。因此,现在可以调试包含此类引用的查询(尽管目前仍无法调试 FormatString 表达式本身),请参阅 #1377。

3.18.0 中的已知问题

  • 如果你在刷新令牌时收到错误信息 Can't obtain account information for '(e-mail)' while trying to refresh the token.,通常重新执行一次操作即可。这是较新版本的 AMO/TOM 客户端库中的一个问题。此外,在首次连接时选择 Microsoft Entra MFA 身份验证选项而不是 集成 选项,也可以避免此问题。

从 Tabular Editor 2.x 迁移过来?

观看 此视频,快速了解 Tabular Editor 3 的主要功能。另外,别忘了查看我们的入门指南。

Tabular Editor 3 主要功能概览:

  • 完全可自定义的 IDE,支持多显示器、Hi-DPI 和主题切换
  • 全新强大的 DAX 代码编辑器,支持自动补全、语法检查、代码折叠等更多功能
  • *工作区模式:可在将更改保存到磁盘的同时,将模型元数据同步到 Analysis Services
  • *支持无限滚动预览表数据、创建 PivotGrid,或编写 DAX 查询来浏览模型或测试计算逻辑
  • *计划数据刷新
  • 在 Provider 和 Structured数据源上更新表架构(没错,连 M 查询也支持!)
  • 创建 Data model 图表
  • 创建 DAX 脚本,让你在单个文档中编辑多个度量值或其他计算对象
  • 录制 C# Script 并保存为宏(以前称为“Custom Actions”)
  • 集成 VertiPaq分析器
  • DAX调试器
  • 集成 DAX优化器
  • 借助代码操作轻松重构 DAX。

*=仅在连接到 Analysis Services 或 Power BI 实例时可用