Table of Contents

Tabular Editor 3.1.2

Important

Tabular Editor 已推出新版本。你可以在这里找到最新版本。

如果你此前未使用过 Tabular Editor 3,则有资格申请 30 天试用,可在安装后提出申请。你也可以购买许可证。

3.1.2 的错误修复

  • 修复了“更新表架构”在 SQL DW / Synapse SQL Pool 数据源上无法工作的问题,参见 #231。
  • 修复了被忽略的规则仍会被 Best Practice Analyzer 纳入考虑的问题,参见 #203。
  • 修复了因 JSON 序列化错误导致模型无法保存到磁盘(文件或文件夹)的问题,参见 #232。
  • 修复了在检查 Structured数据源的属性值时导致崩溃的问题。

3.1.1 的改进

  • 现在可以将共享表达式(Power Query / M 表达式)序列化为单独的文件。你可以在 Tools > 偏好 > Save-to-folder 中控制序列化方式;对于现有模型,则在 Model > 序列化选项... 中设置(参见 #218)
  • 在 Tools > 偏好 > Modeling Operations 下新增选项,用于控制将透视成员关系应用到新对象的方式(参见问题 #216)。
  • 现在可以在序列化时排除 PrivacySetting 属性,以避免 Microsoft.AnalysisServices.Deployment 相关问题。可在 模型 > 序列化选项... 中控制此项(参见问题 #210)。
  • 你现在可以直接在 C# Script 中定义枚举、结构体和类,更便于组织并复用 C# 代码。
  • VertiPaq分析器现新增从数据中收集统计信息的选项(Tools > 偏好 > VertiPaq分析器),可提升统计信息的质量,例如当列的 IsAvailableInMDX = false 时。参见问题 #190。
  • 创建新模型后,Tabular Editor 3 现在会在首次保存时提示你:要将模型保存为文件还是文件夹。你也可以在 工具 > 偏好 > 常规 > 新模型的默认保存格式 中设置默认模式。参见问题 #50。
  • 启动性能已改进(部分用户反馈,在 TabularEditor3.exe 快捷方式中添加 -multicorejit 开关后,启动时间还能进一步缩短)。
  • 重构了“模型”菜单,使“新建计算组”等选项更易找到。
  • 已将 AMO/TOM 客户端库更新到 19.26.1.7。
  • 现在可在 Best Practice Analyzer 中逐个遍历模型角色成员
  • 为避免与 工作区模式 混淆,“窗口”菜单中的“Workspace”已更名为“布局”。
  • 新增 Ctrl+Shift+D 作为“部署”的快捷键
  • 支持新的 DAX 函数(HASH、NAMEOF、COLUMNSTATISTICS、BITAND、BITLSHIFT、BITOR、BITRSHIFT、BITXOR),并支持在 SELECTCOLUMNS 中使用可选的列名参数。

3.1.1 中的错误修复

  • 删除对象时,TOM Explorer 不再会出现卡死或崩溃(参见问题 #223、#209)。
  • 修复了编辑器(#207)和图标(#215)在深色主题下的颜色问题
  • “创建/编辑关系”对话框中的表现在会按字母顺序排序(参见问题 #214
  • 修复了一个 C# Script 问题:该问题会导致无法将 C# Script 保存为宏(参见问题 #208)。
  • 修复了一个问题:数据源密码/凭据未能正确应用到 Workspace 数据库(参见问题 #205)。
  • “选择所有列”复选框不再会导致崩溃(参见问题 #204)。
  • 当脚本使用 #r 预编译指令引用外部 DLL 时,Tabular Editor 现在始终会在安装目录中查找(参见问题 #192)。
  • 修复了语言架构中的一个 Bug,该 Bug 会在某些情况下导致 Q&A 停止工作
  • 在数据预览中对日期列进行筛选不再会导致崩溃
  • 在 TOM Explorer 的透视下拉列表中选择“所有透视”时,不属于任何透视的对象将不再显示。还修复了下拉框无法更新透视名称的问题。
  • 允许将某些 DAX 关键字用作变量(WEEK、DAY、INTEGER 等)且不会显示错误。
  • 修复了一个问题:首次保存模型时,序列化选项未被保存。
  • 修复了 DAX 解析器中的一个问题,该问题会导致在加载模型时崩溃(参见 #229)。

从 Tabular Editor 2.x 升级而来?

观看 此视频,快速了解 Tabular Editor 3 的新功能。 另外,也别忘了查看我们的 入门指南。

Tabular Editor 3 主要功能概览:

  • 完全可自定义的 IDE,支持多显示器、高 DPI 和主题
  • 全新强大的 DAX 代码编辑器,具备自动完成、语法检查、代码折叠等更多功能
  • *工作区模式,可将更改保存到磁盘,并同时将模型元数据同步到 Analysis Services
  • *以无限滚动预览表数据,创建 PivotGrid,或编写 DAX 查询来浏览模型或测试计算逻辑
  • *支持计划数据刷新
  • 在提供程序和 Structured数据源上更新表架构(是的,甚至包括 M 查询!)
  • 创建 Data model 图表
  • 创建 DAX 脚本,让您在一个文档中同时编辑多个度量值或其他计算对象
  • 录制 C# Script 并保存为宏(以前称为“自定义操作”)
  • 集成 VertiPaq分析器

*=仅在连接到 Analysis Services 或 Power BI 实例时才可用