Table of Contents

Tabular Editor 3.3.3

Important

Tabular Editor 已推出新版本。你可以在这里找到最新版本。

如果你此前未使用过 Tabular Editor 3,则有资格申请 30 天试用,可在安装后提出申请。你也可以购买许可证。

重要!

注意:Tabular Editor 3.3.0(及更高版本)使用 .NET 6。在启动 Tabular Editor 3.3.0(或更高版本)之前,你可能需要先安装适用于桌面的.NET 6.0 运行时。从 3.3.1 开始,如果缺少这些先决条件,Tabular Editor 3 安装程序将自动下载并安装它们。

3.3.3 中的改进

  • 导入表向导现已支持从 Power BI Dataflow 导入表。 注意,此选项仅在处理 Power BI Dataset 时可用。此外,Tabular Editor 现在即使在离线工作时(即未连接到 Power BI XMLA endpoint 时),也可以根据 Power BI Dataflow 更新表架构。
  • C# Script:现在输入右括号或右方括号会关闭自动完成框。此外,自动补全框会根据当前搜索字符串预选候选项,这项功能也得到了改进。
  • C# Script:运行时错误信息现在包含堆栈跟踪,调试更方便。
  • 新建 Power BI Dataset 的默认兼容级别现为 1570。
  • 在 工具 > 偏好 > 文件格式 中,我们新增了一组选项,可让你在创建新模型时指定默认兼容级别,以及是否使用 Workspace 数据库。
  • 对于因证书不受信任而导致失败的 SQL Server 连接,现在不会直接抛出连接错误,而是会提示你是否信任该证书并重新连接。
  • 现在可以禁用自动公式修复(位于“工具 > 偏好 > 建模操作”),另请参阅 #595。
  • 新增安装程序的 .msi 版本,适用于无人值守安装或通过软件打包进行安装。
  • 32 位安装程序现在应可在 64 位系统上安装(反之则不行)。
  • 在 TOM Explorer、表格预览、VertiPaq 分析器等位置新增了“锁定列宽”右键菜单选项。选中后,列将始终调整大小以匹配网格宽度,从而改变“最佳匹配(所有列)”的行为。这解决了问题 #603,并且也采纳了 #595 中的一条建议。
  • 在 DAX 查询结果中,右键单击结果列标题时提供更多列选项。例如,你可以隐藏/显示列,显示查找面板以便使用文本快速筛选,甚至按列分组,以分层方式显示查询结果。请注意,对查询结果的排序/分组/筛选仅在本地缓存的结果上进行(通常是查询的前 1000 行)。如果需要对完整数据集执行这些操作,请调整你的 DAX 查询。
  • 现在可以使用基本身份验证从 URL 下载 BPA 规则,参见 #604。

3.3.3 中的错误修复

  • 修复多个与宏编译/执行相关的问题,参见 #587 和 #573。
  • 修复在使用 daxformatter.com 时,通过脚本调用 FormatDax 不起作用的问题,参见 #592。
  • 修复脚本无法调用 Error 和 Warning 全局方法的问题
  • 修复当代码包含带别名的 using 指令时,宏无法编译的问题
  • 修复宏在调用 EvaluateDax 等方法时触发 NullReferenceException 的问题。
  • 修复对未加引号且同时也是关键字的表引用的语法高亮(例如,在 DAX 中 'Currency' 作为未加引号的表引用是合法的,但之前会被当作关键字着色)
  • 移除了对 Visual C++ Redistributable 的依赖,之前在未安装该组件时会导致 Tabular Editor 经常崩溃。

3.3.2 中的错误修复

  • 修复安装程序中的一个错误:执行就地升级时,部分文件不会更新,进而可能导致应用程序崩溃和其他问题,参见 #586。
  • 为 NamedExpression 类新增对 ExpressionSource 属性的支持。

3.3.1 中的改进

  • 全新的安装程序:如果缺少 .NET Runtime 和 VC++ 先决条件,会自动下载并安装。
  • 新增对 DAX NETWORKDAYS 函数的支持。
  • 将 TOM 更新到 19.42.0.4

3.3.1 中的错误修复

  • 修复一个问题:除非从安装文件夹启动应用程序,否则 C# 工具提示不会显示 xmldoc 注释。
  • 语义分析器现在能在将特殊的 MDX 保留关键字用作未加引号的表引用时,正确地报告错误。
  • 修复了一个问题:尝试部署从 .pbit 文件加载的模型时会失败。
  • 修复了 C# Script 和宏的编译问题。参见 #570、#573 和 #580。
  • 修复了一个问题:包含计算组且其中有一个或多个错误度量值的模型无法加载,详见 #571。
  • 修复了一个问题:重新加载模型后,关系图不会自动刷新,详见 #572。
  • 修复了一个问题:C# Script 引擎无法导入某些 DLL,详见 #574。
  • 修复了一个问题:在“本地实例”下拉列表中做出选择后,无法连接到 Power BI Desktop,详见 #579。
  • 修复了一个问题:在 TOM Explorer 中按 CTRL+A 时会选中所有对象(即使已在 TOM Explorer 中进行筛选),详见 #582。
  • 基于匿名遥测和错误 Report 进行了多项稳定性改进。

3.3.0 中的改进

  • 已将 TOM 更新至 19.39.2.2
  • Tabular Editor 3 现在使用 Roslyn 来编译 C# Script。这意味着你的 C# Script 现在可以使用 C# 10.0 的所有强大的新语言特性。此外,你可以直接在脚本中定义类和其他类型。最后同样重要的是,我们终于为 C# Script 提供了由 Roslyn 驱动的 代码补全 和 调用提示(见截图)。 C# 智能感知
  • 同样也别忘了查看我们新的 Scripting API 文档站点,其中包含通过 Tabular Editor 3 的 C# Script 功能可访问的所有对象和成员的最新文档。
  • 我们还改进了 DAX 编辑器的自动补全:自动补全列表现在会显示工具提示,提供列表中对象的更多信息。工具提示将显示度量值、列等对象的 Description。如果未指定说明,我们会显示该对象的 DAX 代码前 10 行: DAX 智能感知改进
  • 通过 Analysis Services 或 Power BI XMLA endpoint 打开模型时,我们现在提供一些选项,帮助你避免误改模型;当你同时打开多个 Tabular Editor 3 实例时尤其有用。模式 下拉列表(见下图)可让你以只读或仅允许读取和刷新的模式打开模型。状态栏颜色 下拉列表可为 Tabular Editor 3 的状态栏设置颜色,便于在不同 Tabular Editor 实例中同时打开生产、测试和开发模型时加以区分。参见 #558。 新的“从数据库打开”选项
  • 我们终于在 TOM Explorer 中添加了“复制对象”上下文菜单选项(Ctrl+D),详见 #501。
  • 新增对 Snowflake OAuth 和 ExternalBrowser 身份验证的支持,详见 #546。
  • 属性网格现已添加搜索栏。
  • 在 工具 > 偏好设置 > 代理设置 下新增更多代理配置选项。
  • 将 SQL Native Client 库更新到最新版本。现在,默认情况下连接到 SQL Server 时需要加密(连接到 localhost 除外)。
  • 在模型、表和分区级别新增 清除刷新 选项,详见 #511。
  • 新增复选框,可在没有 Workspace 数据库的情况下打开 Data model,#523。

3.3.0 的问题修复

  • 修复语义分析器处理 NAMEOF DAX 函数方式的问题,该问题有时会导致崩溃,详见 #538。
  • 属性网格和集合编辑器现已使用 DevExpress 组件,并能在高 dpi 显示器上正确换肤和缩放,详见 #548。
  • 修复一个问题:模型 菜单中的 刷新模型 子菜单有时会消失。
  • “更新表架构...”现在可以正确处理仅大小写发生变化的列名。
  • TE3 商业版现在会阻止向 AS 模型添加多个分区/透视(否则会因版本限制导致 TE3 之后无法再次加载同一模型)。
  • 修复一个问题:编辑器操作有时会被禁用,详见 #519。
  • 修复开始刷新操作后 取消 和 全部取消 按钮未启用的问题。
  • 修复通过 XMLA endpoint 刷新 Power BI 模型时不显示刷新进度的问题。
  • 修复拼写错误,详见 #553。
  • 修复一个问题:即使取消勾选“自动显示参数信息”设置,调用提示仍会出现,详见 #545。
  • 修复注释/取消注释功能的 bug,详见 #536。
  • 修复 CUSTOMDATA() 返回类型错误的问题,详见 #527。
  • 在数据预览中,当使用 FILTER 筛选字符串列的“(空白)”时,现在会同时包含 BLANK 和 "" 字符串,详见 #524。
  • 修复一个问题:在通用“打开文件”对话框中,当下拉列表选择“所有文件”时,尝试打开 Database.json 文件会出现“Tabular Editor 无法打开指定文件”错误。另请参见 #563。
  • 修复“保存”功能未遵循“序列化设置”复选框选择的问题。
  • 修复状态栏中链接颜色的显示问题。参见 #521。
  • 修复在偏好设置对话框中尝试清除孤立的跟踪信息时导致崩溃的问题。
  • 修复与变体比较时出现语义错误误报的问题,参见 #516。
  • 修复调试包含 IF/SWITCH 函数调用的变量赋值时 DAX 生成的问题,参见 #513。
  • 不再允许将 WEEK 作为 DATEADD 的间隔参数。参见 #508。
  • 在计算组表上显示计算项错误指示器,见 #506。
  • 修复 C# Script 方法 ImportProperties 无法正确解析对象路径的问题。
  • 当安装数量超出限制时,添加指向自助服务门户的链接。更新了多个位置的 URL/链接
  • 在调试 USERELATIONSHIP 时改进 DAX 代码生成。
  • 允许取消勾选“保存模型元数据备份”的偏好设置。改进模型元数据备份失败时的错误提示。允许取消模型元数据备份。
  • 修复了 REMOVEFILTERS 的问题。参见 #562。

从 Tabular Editor 2.x 升级过来?

看看 此视频,了解一下 Tabular Editor 3 的新功能。另外,也别忘了查看我们的入门指南。

Tabular Editor 3 主要功能概览:

  • 完全可定制的 IDE,支持多显示器、Hi-DPI 和主题
  • 全新强大的 DAX 代码编辑器,提供自动完成、语法检查、代码折叠等丰富功能
    • 工作区模式:允许你将更改保存到磁盘,同时将模型元数据同步到 Analysis Services
  • *通过无限滚动预览表数据,创建 PivotGrid 或编写 DAX 查询,用于浏览模型或验证计算逻辑
  • *安排数据刷新
  • 更新 Provider 和 Structured数据源的表架构(没错,连 M 查询也支持!)
  • 创建 Data model 示意图
  • 创建 DAX 脚本,可在单个文档中编辑多个度量值或其他计算对象
  • 录制 C# Script 并将其保存为宏(以前称为“自定义操作”)
  • VertiPaq分析器集成
  • *DAX调试器

*=仅在连接到 Analysis Services 或 Power BI 实例时适用