Tabular Editor 3.4.0
Important
Tabular Editor 已推出新版本。你可以在这里找到最新版本。
Tabular Editor 3.4.0 下载:
- 下载 Tabular Editor 3.4.0(64 位) (推荐)
- 下载 Tabular Editor 3.4.0(32 位)
- 便携版:x64、x86
- MSI 版本:x64、x86
如果你之前未使用过 Tabular Editor 3,则可以申请 30 天试用;安装完成后即可提交申请。你也可以购买许可证。
重要!
注意:Tabular Editor 3.3.0(及更高版本)使用 .NET 6。在启动 Tabular Editor 3.3.0(或更高版本)之前,你可能需要先安装 适用于桌面的.NET 6.0 运行时。从 3.3.1 开始,如果缺少这些先决条件,Tabular Editor 3 安装程序会自动下载并安装它们。
3.4.0 中的新功能
- 将 TOM 更新到 19.54.1。
- Tabular Editor 3 现已支持在 Power BI Desktop 2022 年十二月更新中宣布的 新 DAX 窗口函数。
- 现已支持自定义键盘快捷键!想无论在什么上下文中都始终使用 CTRL+S 保存模型吗?想为模型刷新设置一个热键吗?或者为编辑器设置一个快捷键,用于选择当前所选内容的所有匹配项?此功能可在 工具 > 偏好 > 键盘 下找到。更多信息请参阅“偏好”中的这里。
- 所有代码编辑器现在除支持矩形选择(拖动时按住 ALT,或使用 SHIFT + 方向键)外,还支持多重选择(即按住 CTRL 并用鼠标拖动,以创建新的选区)。
3.4.0 中的小幅改进
- Tabular Editor 3 现在会在 Power BI“外部工具”功能区中显示正确的图标。
- 在属性网格中可集中编辑列类型的属性。现在可以在属性网格中通过输入列名来指定列。当列数超过 7 个时,将弹出“选择列”对话框,而不是下拉菜单。这也修复了问题 #738。
- 在“表格预览”中移除了列名中的方括号
- 现在可以在导入表向导中连接并选择其他 Power BI Workspace。
- Pivot Grid 字段列表现在可以作为可停靠窗口使用,参见 #742。
- 当源描述中包含 HTML 标记时,DAX 调用提示现在也能正确排版。
- 现在,所有代码编辑器在使用键盘进行选择时,矩形选区功能都有了大幅改进。此外,在矩形选区下,复制/粘贴的操作现在更直观。
- 在“工具 > 自定义”对话框(位于“Options”选项卡下)中新增了锁定菜单和工具栏的选项,以防止误将其拖动。
- Scintilla 的多重选择“添加下一个/逐个添加”现在会遵循“查找”对话框中设置的搜索选项。
- 允许 File.SaveModel 快捷键在任何上下文下都能生效,参见 #762。
- 现在可以取消长时间运行的保存操作,例如数据库因刷新操作而被锁定时。参见 #730。
- 创建/编辑关系对话框现在支持调整大小,参见 #732。
- 允许在所有树形列表上用方向键展开/折叠(包括 BPA、依赖关系视图和数据刷新视图),参见 #775。
- 我们已听取大家的反馈!“显示表的关系”已回归到依赖关系视图,参见 #731。
3.4.0 Bug 修复
- AAD 连接对话框现在在所有情况下都会以模态对话框显示。
- 批量编辑多个对象时,会创建撤销事务
- 现在可以通过右键点击并选择“重置”来清除对象属性(例如 SortByColumn)。
- 新增右键快捷方式,用于编辑表表达式属性(SourceExpression、PollingExpression 等)现已提供,参见 #721。
- 将字段拖到 Pivot Grid 上时,Pivot Grid 不再冻结,参见 #676。
- 修复问题 #723。
- 修复了在从 .tmuo 文件中指定的现有 Power BI Dataflow 导入时,会导致表架构无法更新并使“导入表向导”崩溃的问题。
- 修复了 DAX调试器生成的观察表达式 DAX 查询无效的问题,参见 #770。
- 修复了一个问题:该问题有时会导致调试器窗口崩溃(白色背景上显示红色叉号)。
- 修复了一个问题:“导入表向导”有时会显示名称为空的 Dataflow。
- “还原”按钮现在会始终处于启用状态。此外,只有在进行了更改后才会显示确认提示。参见 #729。
- 显示字段列表不再清空 Pivot Grid,参见 #741。
- 修复了一个问题:应用启动时,TOM Explorer 中的列有时会被“截断”。
- TOM Explorer 现仅允许在 Power BI 数据集中添加 EntityPartitions
- 修复依赖项视图崩溃问题,参见 #758
- 修复了一个问题:应用程序重启后,浮动窗口可能会出现在可见屏幕区域之外。参见 #652。
- 修复“最近使用的服务器”未保存的问题。
- 修复了“模型”和/或“上下文”菜单中操作显示方式相关的几个问题。例如,“模型”菜单中的“Script DAX”只会为当前选择中的对象生成脚本,而按设计应为模型中的所有对象生成脚本。
- 修复文本编辑器横向滚动条的行为。
- SQL 连接对话框现在会将对连接字符串所做的更改保存下来,参见 #755。
- 现在,在“选择数据库”对话框中筛选列表后再选择数据库,可以确保实际加载的是正确的数据库。参见 #761。
- 修复在表格中滚动时的问题 (参见 #733,以及应用筛选条件时行数不更新的问题。
Tabular Editor 3 团队祝大家节日愉快,新年快乐!
从 Tabular Editor 2.x 升级过来?
观看此视频,了解 Tabular Editor 3 的新功能。另外,也别忘了查看我们的入门指南。
Tabular Editor 3 主要功能概览:
- 完全可自定义的 IDE,支持多显示器、高 DPI 和主题
- 全新强大的 DAX 代码编辑器,具备自动补全、语法检查、代码折叠等众多功能
- *Workspace 工作区模式:在将更改保存到磁盘的同时,将模型元数据同步到 Analysis Services
- *支持无限滚动预览表格数据,可创建 PivotGrids 或编写 DAX 查询来浏览模型或测试计算逻辑
- *支持计划数据刷新
- 在 Provider 数据源和 Structured数据源上更新表架构(没错,连 M 查询也支持!)
- 创建 Data model 关系图
- 创建 DAX 脚本,在单个文档中编辑多个度量值或其他计算对象
- 录制 C# Script 并保存为宏(此前称为“Custom Actions”)
- 集成 VertiPaq分析器
- *DAX调试器
*=仅在连接到 Analysis Services 或 Power BI 的实例时