Table of Contents

保存到文件夹

使用“保存到文件夹”,你可以将模型元数据存储为独立文件,便于用版本控制系统进行管理。你不必再使用一个包含 Data model 中所有对象(例如表、度量值、关系等)的单一文件 (.bim 或 .pbix),而是可以将它们拆分为多个独立文件,并存放在一个文件夹中。这样一来,你就可以使用版本控制系统来跟踪更改、比较版本,并与其他开发者协作开发你的 Data model。

Note

你可以使用两种不同的格式将 Data model 保存到文件夹:JSON 或 TMDL。

要把模型保存到文件夹,按以下步骤操作:

  1. 点击“文件 > 保存到文件夹”
  2. 选择用于保存模型文件的文件夹。
  3. 点击“保存”。 Tabular Editor 会在所选文件夹中创建或更新文件,并根据序列化设置以指定的 JSON 或 TMDL 格式保存。
  4. 现在,你可以将该文件夹中的文件用于版本控制、部署或备份。

序列化设置

序列化设置用于定义如何将模型对象拆分为单独的文件。在这些设置中,你还可以选择使用 JSON 或 TMDL 格式。

序列化设置位于“文件 > 偏好 > 序列化”。

TE2 偏好

上面所示的设置是 Tabular Editor 3 的默认设置,但并非 Tabular Editor 2.X 的默认设置

用户自定义函数(UDFs)

自 Tabular Editor 3.27.0 起,JSON 文件夹格式可将每个 DAX 用户自定义函数 分别存储为独立文件,与表、度量值和列的存储方式一致。这些函数位于模型根目录下的 functions 子文件夹中:

MyModel/
├── database.json
├── functions/
│   ├── Sales.MarginPct.json
│   └── Time.SameDayLastYear.json
├── tables/
└── ...

好处与其他任何对象类型相同:两位开发人员分别编辑两个不同的函数时,会修改两个不同的文件,因此 Git 没有任何需要合并的内容。如果不启用它,每个函数都会以内联方式保存在 Database.json 中,任何两项并行编辑都会在这一个文件里发生冲突。

可在 工具 > 偏好 > 文件格式 > 保存到文件夹 下启用 用户自定义函数(UDFs) 级别;对于当前打开的模型,也可在 模型 > 序列化选项... 中启用。

模型 > 序列化选项,其中已勾选“用户定义函数(UDFs)”级别

Important

只有在你_首次_将模型保存到文件夹时,Tabular Editor 才会默认选中此级别。已采用文件夹序列化的模型会在自身的序列化注释中保留已存储的级别,因此在你于 模型 > 序列化选项... 中选择 用户自定义函数(UDFs) 并再次保存模型之前,这些函数仍会继续以内联方式存储。

序列化模型注释

Tabular Editor 会将序列化设置保存在模型中,这样无论谁在处理该模型,这些设置都会保持一致。这可确保开发者的本地偏好不会覆盖模型的设置,从而避免在源代码管理中出现难以处理的合并冲突。你可以在 TOM Explorer 的“Model”对象属性中找到这些注释,路径为:Model > Annotations > TabularEditor_SerializeOptions

TE3 偏好

覆盖模型序列化设置

如果需要,可以覆盖模型上的注释。先在 Tabular Editor 中设置好序列化偏好,然后选择“文件 > 保存到文件夹”。这会打开 Windows 资源管理器,此处需要取消勾选该复选框。

TE3 偏好