加载与保存模型元数据
Tabular Editor 可将模型元数据从文件、文件夹或服务器读取到内存中,并将其写回原位置或另存到新位置。
加载模型

| 来源 | 命令 |
|---|---|
Model.bim 或 .bim 文件 |
文件 > 打开 > 从文件打开模型... |
| 采用 JSON 或 表格模型定义语言 (TMDL) 格式的文件夹结构 | 文件 > 打开 > 从文件夹打开模型... |
| Analysis Services 或 Power BI XMLA 数据库 | 文件 > 打开 > 从数据库打开模型... (Ctrl+Shift+O) |
| Power BI Desktop 的运行实例 | 文件 > 打开 > 从数据库打开模型...,或从 Power BI Desktop 的 外部工具 功能区启动 Tabular Editor |
.bim 文件的兼容级别必须为 1200 或更高。更早的级别使用较旧的基于 XML 的格式,Tabular Editor 无法打开此类格式。
如需了解 Tabular Editor 可识别的所有内容(包括并非模型元数据的受支持文件类型),请参阅支持的文件类型。
Tip
文件 > 最近使用的表格模型 可重新打开你之前打开过的模型。
保存模型
文件 > 保存 (Ctrl+S) 会将模型保存回您加载它的位置。从文件加载的模型会写回到该文件。从文件夹加载的模型会以该文件夹当前使用的格式保存回该文件夹。从数据库加载的模型会部署回该数据库。
若要将模型写入其他位置,或改用其他格式:
- 文件 > 另存为... 会将模型元数据保存为单个
.bim文件。 - 文件 > 保存到文件夹... 会将模型元数据保存为文件夹结构,格式可以是 JSON 或 TMDL,具体取决于 工具 > 偏好 > 文件格式 > 保存到文件夹 下设置的序列化模式。
Important
从旧版 JSON 文件夹结构加载的模型,在使用 文件 > 保存 时会按相同格式保存,即使你的偏好中设置的是 TMDL。只有在使用 文件 > 保存到文件夹... 时,格式才会更改。参见 TMDL。
重新加载
文件 > 从磁盘重新加载 会丢弃自上次保存以来所做的所有更改,并从源位置重新加载元数据。如果你有未保存的更改,会先显示 重新加载模型元数据? 提示。命令标签取决于模型源:
| 模型源 | 命令 |
|---|---|
| 文件或文件夹 | 从磁盘重新加载 |
| 处于Workspace 工作区模式的模型 | 从磁盘重新加载。模型会从其文件重新加载,并重新部署到 Workspace 数据库。 |
| Analysis Services 或 Power BI(不处于 Workspace 工作区模式) | 从服务器重新加载 |
| 未加载任何模型 | 从源重新加载(已禁用) |
在 Tabular Editor 3.26 及更早版本,以及 Tabular Editor 2 中,该命令名为 文件 > 还原。
在 Tabular Editor 3.27.0 及更高版本中,当代理、脚本或 git pull 更改了已打开模型的元数据文件时,模型会重新加载;如果你有未保存的更改,则会先显示提示。参见 从磁盘自动重新加载。
Warning
在让任何工具写入模型元数据之前(包括 Tabular Editor),请先备份。保存会覆盖源,重新加载无法找回你已保存的更改。
后续步骤
- 保存到文件夹:了解文件夹格式,以及控制如何将模型拆分到多个文件中的序列化设置。
- 如果有多人共同处理这个模型,参见 使用 Git 和保存到文件夹启用并行开发。
- 部署:将模型写入 Analysis Services 服务器。