Tabular Editor 3 偏好设置
不同组织的表格式 Data model 开发流程和工作流差异很大。为确保该工具能够适配尽可能多的工作流,Tabular Editor 3 高度可定制——不仅可以自定义用户界面的外观与使用体验,还支持配置更高级的选项,例如 Web 代理、更新和反馈、行数限制、超时、架构比较偏好等。
本文介绍 Tabular Editor 3 的“偏好设置”对话框,以及你可以通过该对话框控制的设置。
要打开“偏好设置”对话框,请依次选择 工具 > 偏好。
Note
所有 Tabular Editor 偏好设置都会针对每个 Windows 用户配置文件分别存储在 %localappdata%\\TabularEditor3 文件夹中。只需复制此文件夹中的内容,即可将你的设置迁移到另一台计算机。
Tip
在“偏好”对话框顶部使用搜索框,可快速找到特定设置。
Tabular Editor > 功能

Power BI
允许不受支持的编辑(已禁用)
仅当将 Tabular Editor 3 作为 Power BI Desktop 的外部工具使用时,此选项才适用。选中后,连接到 Power BI Desktop 实例时,所有 TOM Data model 的建模属性都可供编辑。通常建议保持此项未选中,以免你无意中对 Power BI 文件做出 Power BI Desktop 不支持的 更改。
隐藏自动日期/时间警告(已禁用)
选中后,将不再显示有关 Power BI 自动日期/时间表的警告。当 Power BI Desktop 中启用“自动日期/时间”设置时,会创建计算表格,从而触发 Tabular Editor 3 内置 DAX 分析器的警告。
在 DAX 首行换行(已禁用)
在 Power BI Desktop 中,由于公式栏显示 DAX 代码的方式,通常会在 DAX 表达式的第一行插入换行。如果你经常在 Tabular Editor 和 Power BI Desktop 之间来回切换,可以考虑启用此选项,让 Tabular Editor 3 自动插入换行符。
仅适用于多行 DAX 表达式(已启用)
启用“DAX 首行换行”后,此子设置用于控制是否仅对多行 DAX 表达式添加换行。选中后,单行表达式将保持不变。
默认 Power BI 身份验证模式(集成)
选择连接到 Power BI Dataset 时要使用的默认身份验证方法(集成、ServicePrincipal 或 MasterUser)。
最佳实践分析器
在后台扫描最佳实践违规项(已启用)
如果未勾选,你需要在 Best Practice Analyzer 工具窗口中手动运行一次“最佳实践分析”,才能查看是否存在违规项。选中后,每当发生更改,都会在后台线程中持续扫描。对于非常大的模型,或包含非常复杂的最佳实践规则的模型,这可能会导致问题。
内置 BPA 规则(新用户默认启用)
选择启用、禁用,或在使用 Tabular Editor 内置的 Best Practice Analyzer 规则前进行提示。这些内置规则覆盖了格式设置、元数据、模型布局、DAX 表达式和翻译等方面的关键最佳实践。全新安装默认会启用内置规则。
通知
数据刷新通知(已启用)
勾选后,数据刷新操作完成时会显示通知。
DAX 公式自动修正
启用公式修复(已启用)
当对象被重命名或移动时,自动调整 DAX 表达式中的引用。此功能可确保你在重新组织模型时,DAX 代码仍然有效。
粘贴时启用公式修复(已启用)
在粘贴对象时,自动调整 DAX 表达式中的引用。这在表或模型之间复制度量值或计算列时非常有用。
Direct Lake
保存时自动刷新(已启用)
保存更改时自动刷新 Direct Lake 表,确保数据为最新。这样可确保你的 Direct Lake 模型与底层数据源保持同步。
Tabular Editor > 更新与反馈

更新
在更新后显示“开始使用”页面(已启用)
勾选后,Tabular Editor 更新后首次运行时会自动打开 开始使用 页面。它仅在更新后显示,不会在每次启动时都显示。你可以随时通过 帮助 > 开始使用 打开它。
启动时检查更新(已启用)
勾选后,Tabular Editor 会在应用启动时检查是否有新版本。这可确保你及时获取最新功能和错误修复信息。
仅限主要更新(已禁用)
勾选后,只有主版本更新才会触发通知。次要版本和补丁更新会被忽略。只有勾选 启动时检查更新 时,此设置才可用。
在这些设置下方会显示你当前运行的版本,并提供一个 检查更新 按钮,可立即执行检查。
由你的组织管理
如果管理员已配置策略,此页面会附加一个只读的 由你的组织管理 部分,其中按 名称 = 值 列出 Tabular Editor 找到的每个策略值。将鼠标悬停在某项上,可查看它来自哪个注册表项和注册表配置单元。
Tabular Editor 无法解析的值不会被省略,而是会以 (invalid) 标记列出。该标记能最快帮你找出那些看似不起作用的策略背后的拼写错误,因此当策略未生效时,先检查这里。
没有适用策略时,不会显示此部分。被策略锁定或限制的设置,会在此对话框的其他位置以及 工具 > MCP 服务器... 对话框中以只读方式显示,并带有相应说明的工具提示。
使用数据和反馈
通过收集匿名使用数据帮助改进 Tabular Editor(已启用)
数据不包含任何可识别个人身份的信息,也不包含任何有关你的 Data model 的结构或内容的信息。如果你仍希望选择退出遥测,请取消选中此项。
发送错误 Report(已启用)
勾选后,如果发生崩溃,Tabular Editor 会显示发送崩溃 Report 的选项。崩溃 Report 在调试时非常有帮助,所以如果你不介意,就保持勾选此项吧!
Tabular Editor > 部署

使用 Deployment Wizard 时,配置默认要部署的对象类型:
部署数据源(已禁用)
部署时包含数据源定义。如果你希望在部署模型更改的同时部署数据源连接字符串和设置,请启用此选项。
部署分区(已禁用)
部署时包含分区定义。如果你希望在部署模型更改的同时部署分区配置,请启用此选项。
部署刷新策略分区(已禁用)
部署时包含增量刷新策略分区。此选项用于控制是否部署由增量刷新策略创建的分区。
部署模型角色(已禁用)
在部署时包含角色定义。若要部署行级安全性(RLS)和对象级安全性(OLS)角色,请启用此选项。
部署模型角色成员(已禁用)
在部署时包含角色成员分配。若要部署安全角色的用户和组分配,请启用此选项。
部署共享表达式(已禁用)
部署时包括共享表达式(M 表达式)。如需部署 Power Query 共享表达式,请启用此选项。
部署元数据
标注部署元数据(已禁用)
将部署时间戳和用户信息作为注释添加到已部署的对象中。这有助于跟踪模型更改是在什么时候、由谁部署的。
备份设置
保存时备份(已启用)
在本地保存更改时创建模型备份。这样可在需要回退更改时提供一道安全保障。
备份保存位置
指定存放保存备份的文件夹。默认情况下,除非指定位置,否则不会创建备份。
部署时备份(已启用)
在部署更改之前,为目标模型创建备份。这样可在需要时还原到先前版本。
备份位置
指定存放部署备份的文件夹。默认情况下,除非指定位置,否则不会创建备份。
Tabular Editor > 默认设置
新模型兼容级别(1600)
设置新建模型的默认兼容级别。可选项与 新建模型 对话框中的相同:
| 级别 | 目标 |
|---|---|
| 1200 | Azure Analysis Services / SQL Server 2016+ |
| 1400 | Azure Analysis Services / SQL Server 2017+ |
| 1500 | Azure Analysis Services / SQL Server 2019+ |
| 1600 | Azure Analysis Services / SQL Server 2022+ |
| 1700 | Azure Analysis Services / SQL Server 2025+ |
| 1706 | Power BI / Fabric |
1700 是 Analysis Services 支持的最高级别;1706 是总体最高级别,仅适用于 Power BI 和 Fabric。
将最新兼容级别设为默认(已启用)
新模型会自动使用最新可用的兼容级别。启用后,此设置会覆盖上方的特定兼容级别设置,并且下拉列表会被禁用。
新模型使用 Workspace 数据库(已启用)
创建新模型时,会在 Analysis Services 上自动创建一个 Workspace 数据库。这样你就可以在开发过程中立即测试并查询模型。
默认保存模式(AlwaysAsk)
选择保存时是始终保存为文件(.bim)、文件夹(多个 JSON 文件)、TMDL(Tabular Model Definition Language),还是每次保存都询问。选项:AlwaysAsk、File、Folder、TMDL。
保存到磁盘时使用 PBIX 文件名(已启用)
保存从 PBIX 文件加载的模型时,默认使用 PBIX 文件名。这可确保 Power BI 文件与已保存的模型元数据在命名上保持一致。
为新模型创建用户选项(已启用)
为新模型自动创建 .tmuo(Tabular Model User Options)文件。这些文件会存储特定于用户的设置,例如图表布局和窗口位置。
Tabular Editor > 键盘

为所有 Tabular Editor 命令配置键盘快捷键。使用搜索功能可快速找到特定命令,并分配或修改其键盘快捷方式,使其符合你偏好的工作流程。
Tabular Editor > TOM Explorer

控制 TOM (Tabular Object Model) Explorer 如何显示模型,以及删除对象时的处理方式。
用于决定树状结构中显示哪些对象类型的开关,例如度量值、列、层次结构、分区、显示文件夹和隐藏对象,并不属于偏好设置。这些开关位于 TOM Explorer 视图 工具栏上,你可以按模型分别更改它们,而无需打开此对话框。
显示与筛选
使用表格组(已启用)
在 TOM Explorer 中对表进行分组,例如将计算组、维度表和事实表区分开来。 Tabular Editor 会将表的组别记录在表自身的注释中,因此分组信息会随模型一起保存。这是 Tabular Editor 的内部功能:任何其他客户端工具(包括 Power BI Desktop)都不会显示它。参见 @table-groups。
显示完整分支(已禁用)
当你对树状结构进行筛选时,Tabular Editor 会显示与筛选字符串匹配的对象及其父对象。启用此项后,还会显示每个匹配项的所有子对象,无论这些子对象本身是否匹配该字符串。
突出显示关系(已启用)
突出显示与你所选表或列相关的关系,这样你就能一眼看出某列关联到了哪些对象。
未保存的更改
这些设置用于控制如何在 TOM Explorer 和属性视图中标识未保存的更改。
标记有未保存更改的对象(已启用)
在 TOM Explorer 中,使用着色行和对象图标上的标记来突出显示与模型上次保存版本不同的对象:橙色表示已编辑对象,绿色表示已添加对象,红色表示已删除对象。包含已更改对象的表、文件夹和组会以斜线纹理填充。禁用后,已删除对象仍会根据下方设置保持可见,且 显示更改 工具栏筛选器仍然有效。使用 用户界面 > 辅助功能 下的 色盲模式,可将新增对象标记为蓝绿色而不是绿色。
让已删除的对象保持可见(直到保存模型)
控制已删除对象在 TOM Explorer 中以删除线形式保留在原位置可见的时长。右键单击已删除对象并选择 还原,即可将其恢复。选项:
- 从不:已删除对象会立即从 TOM Explorer 中消失。
- 直到模型保存:已删除对象会被视为未保存的更改,并在保存模型时消失。
- 直到模型关闭:已删除对象在整个编辑会话期间都会保持可见,并且可还原,即使期间多次保存也是如此。
将已删除对象集中到“已删除对象”节点下(禁用)
将表、层次结构、角色或表格组的已删除对象集中显示在各自容器末尾的单个 已删除对象 节点下,而不是分别显示在原来的位置。右键单击该节点并选择 还原,即可一次性还原全部对象。
在属性窗格中标记带有未保存更改的属性(启用)
在属性视图中,用带底色的行突出显示与模型上次保存版本不同的属性。禁用后,属性视图中的 显示更改 工具栏筛选器仍然有效。
删除
始终显示删除警告(已禁用)
如果你希望 Tabular Editor 3 在删除任何对象时都要求你确认,请启用此设置。否则,Tabular Editor 3 只会在删除多个对象时,或删除被其他对象引用的对象时提示你确认。
Note
在 Tabular Editor 3 中,所有删除操作都可以按 CTRL+Z 撤销。
本地化
这些设置决定了当你在属性窗格中为对象选择 货币 数字格式时,Tabular Editor 将写入的格式字符串。
默认货币(英语(美国))
用作货币格式字符串基础的格式约定。选择你希望采用其货币符号、小数分隔符和数字分组方式的区域设置。
使用自定义货币符号(禁用)
使用你自己的符号,而不是采用上方区域设置中的符号。仅在勾选此项时,下面三个设置才会生效。
自定义货币符号
要使用的符号。仅输入符号本身,不要包含数字;空白字符会被忽略。
自定义货币符号位置(数字前)
指定符号位于数值之前还是之后。
在数字和符号之间添加空格(已禁用)
使用空格将符号与数值分隔开。
Tabular Editor > 复制/粘贴
控制复制对象时包含哪些元数据:
包含翻译(已启用)
随对象一起复制翻译元数据。启用后,复制对象时也会一并复制为其定义的所有翻译。
包含透视(已启用)
复制对象时同时复制透视成员关系。启用后,复制的对象将与原对象属于相同的透视。
包含 RLS(已启用)
随对象一起复制行级安全性表达式。这适用于复制已定义 RLS 规则的表。
包含 OLS(已启用)
复制对象时同时复制对象级安全性设置。在复制带有 OLS 限制的对象时适用。
Tabular Editor > 透视
控制如何处理透视成员资格:
新对象继承透视成员资格(已禁用)
新建对象会自动从其父对象继承透视成员资格。例如,新度量值会自动添加到与其父表相同的透视中。
移动后的对象继承透视成员资格(已禁用)
被移动的对象会从其新的父对象继承透视成员资格。这在重新组织模型结构时很有用。
将表添加到透视时继承(已启用)
将表添加到透视时,自动添加该表的所有对象(列、度量值、层次结构)。
从透视中移除表时一并移除(已启用)
从透视中移除表时,自动移除该表的所有对象。
Tabular Editor > 架构比较

配置在更新表架构并进行架构比较时要忽略哪些更改:
忽略导入模式更改(已禁用)
不要标记对导入模式属性的更改。如果希望在架构比较期间忽略导入模式、DirectQuery 模式和 Dual 模式之间的更改,请启用此选项。
忽略数据类型更改(已禁用)
不要标记对列数据类型的更改。如果希望在架构比较期间忽略数据类型更改,请启用此选项。
忽略描述更改(已禁用)
不要标记对对象描述的更改。如果你不想在架构比较中看到描述的更改,请启用此选项。
忽略 decimal 与 double 之间的更改(已禁用)
不要将 decimal 与 double 数据类型之间的更改标记为差异。这在处理不区分这些类型的数据源时很有用。
优先使用 Analysis Services 架构检测器(已禁用)
将 Analysis Services 元数据作为架构检测的最终依据。启用后,Tabular Editor 将直接查询 Analysis Services 实例,而不是使用数据源提供程序的架构信息。
Tabular Editor > 保存到文件夹/文件

序列化模式
使用 TMDL 格式(已禁用)
使用 Tabular Model Definition Language(TMDL)格式而非 JSON 来保存模型元数据。 TMDL 是推荐用于版本控制和协作的现代格式。
使用推荐的序列化设置(已启用)
应用基于文件夹的序列化推荐设置(会覆盖自定义设置)。启用后,Tabular Editor 会使用将模型保存到文件夹的最佳实践,并针对版本控制进行优化。
传统(JSON)序列化设置
为文件名添加前缀(已禁用)
为文件名添加数字前缀以便排序。这有助于在文件浏览器中保持一致的文件顺序。
本地关系(已启用)
将关系定义与各个表一起存储,而不是集中存放在一个位置。这使得在使用版本控制时,更容易看清每个表包含哪些关系。
本地透视(已启用)
将透视成员隶属信息随各个对象单独存储,而不是集中存放在一个位置。这可以减少版本控制中的合并冲突。
本地翻译(已启用)
将翻译与各个对象一起存储,而不是集中保存在一个位置。这可以减少版本控制中的合并冲突。
级别
选择要在不同文件夹级别序列化的对象类型。这让你可以将模型文件组织成分层结构。可用的级别包括数据源、用户定义函数(UDF)、共享表达式、透视、关系、角色、表、列、层次结构、度量值、分区、计算项和翻译。
忽略推断对象(已启用)
不要序列化由引擎自动推断的对象。这可以减少已保存元数据的杂乱。
忽略推断属性(已启用)
不要序列化由引擎自动推断的属性。这会让已保存的元数据保持整洁,只包含显式设置的值。
忽略时间戳(已启用)
不要序列化时间戳元数据。强烈建议在版本控制中启用此选项,因为它可以避免每次提交都产生不必要的更改。
忽略 Lineage tag(已禁用)
不要序列化 Power BI 的 Lineage tag 元数据。如果你不希望已保存的元数据中包含谱系信息,就启用此选项。
忽略隐私设置(已禁用)
不要序列化数据源隐私设置。如果你单独管理隐私设置,请启用此选项。
包含敏感数据(已禁用)
在序列化的元数据中包含密码等敏感信息。出于安全原因,不建议这样做。
忽略增量刷新分区(已禁用)
不要序列化由增量刷新的刷新策略创建的分区。如果你希望将增量刷新与已保存的元数据分开管理,请启用此选项。
拆分多行字符串(已启用)
将较长的字符串值拆分为多行,便于在版本控制中阅读。这能让你更容易看清 DAX 表达式以及其他长文本属性的改动。
排序数组(已禁用)
按字母顺序对数组元素排序,以确保序列化结果一致。这可以减少版本控制中无意义的差异,但也可能改变某些元素的逻辑顺序。
TMDL 序列化设置
缩进模式(制表符)
选择在 TMDL 文件中使用制表符或空格进行缩进。制表符是默认且推荐的选项。
缩进空格数(4)
使用空格时,指定每级缩进的空格数。
AI 功能
父级页面包含两项适用于所有 AI 功能的设置,对聊天和 MCP server 均适用。
启动时检查知识库更新(已启用)
AI 助手会搜索 Tabular Editor 文档的本地副本。选中后,Tabular Editor 会在启动时检查是否有更新的副本,如有可用则下载。这是任何 AI 功能自行发起的唯一一次出站请求。
审计日志
打开审计文件夹会打开本机的一份记录,记录了 AI 助手和 MCP 服务器的操作:权限决策、调用了哪些工具及其结束方式,以及任何已运行或提交供审核的脚本全文。提示词、回复和数据值绝不会被记录。这项记录功能仅限企业版:Desktop 和 Business 版不会记录任何内容,也不会显示该按钮。参见 @ai-audit-log。
AI 功能 > AI 助手
AI 助手聊天的连接设置。 AI 提供程序子页面会显示在这里。各提供程序需要哪些信息,请参见 @ai-assistant。
选择提供程序(无)
聊天要连接的 AI 提供程序:OpenAI、Anthropic、Azure OpenAI 或 自定义(兼容 OpenAI)。下方字段会根据你的选择而变化。管理员可以通过策略把它锁定为单个提供程序,或缩小可选列表。
基础 URL / 服务端点
请求会发送到这里。 OpenAI 和 Anthropic 都提供默认值,所以这个字段是可选的。 Azure OpenAI 和自定义没有默认值,因此必须填写端点。
API 密钥
用于所选提供商的自有密钥。它会以加密方式存储在本机的偏好设置文件 Preferences.json 中。 Tabular Editor 不提供内置密钥,也绝不会代理你的请求。
OpenAI 组织 ID 和 OpenAI 项目 ID
可选,并且只在选择 OpenAI 提供程序时显示。当你的 OpenAI 账户按组织或项目计费,或将使用范围限定到组织或项目时,可以使用这些字段。
模型名称(在 Azure OpenAI 中为 部署)
要使用的模型。对于 OpenAI 和 Anthropic,这里是一个从在线目录加载的下拉列表,因此在此计算机上首次获取目录之前会显示为空。对于 Azure OpenAI,该字段标记为 部署,填写的是你为该部署指定的名称,这个名称不一定是底层模型的名称。留空时会使用提供程序的默认值;Azure OpenAI 和 Custom 除外,因为它们没有默认值。
AI 功能 > AI 助手 > 偏好
聊天的行为方式。有关各分组的详细说明,请参见 @ai-assistant。
聊天显示
显示选择上下文指示器(已启用)
在聊天上方显示当前选中的模型对象,以便你了解助手会将哪些内容视为上下文。
显示自定义指令指示器(已启用)
在每条回复上方显示本次应用了哪些自定义指令。
显示知识库搜索指示器(已启用)
在助手搜索知识库时显示进度。
上下文压缩
自动压缩(已启用)
当对话接近模型的上下文限制时,自动总结较早的对话内容,让长对话可以继续进行。
自动压缩阈值 %(80)
压缩运行前,上下文窗口最多可填充到多满;这里按 模型自身 窗口的百分比计算,而不是固定的 token 数量。超出 50 到 100 范围的值不会再产生额外效果。
C# Script
允许 AI 助手直接运行 C# Script(已禁用)
让助手直接执行你要求的模型更改,而不是先编写脚本再打开给你运行。只有通过安全分析并被认定为安全的脚本才会以这种方式运行,也就是只操作模型对象、不做其他事情的脚本;任何涉及文件、网络或外部程序集的内容,仍会交由你审核。每次运行都会作为一个单独的撤销步骤记录。
在 权限 页面将 模型元数据 设为 写入 之前,此设置不可用;切换该下拉列表后无需关闭对话框,设置会立即生效。如果管理员设置了 DisableCSharpScripts 策略,该选项同样不可用,并会显示工具提示说明这一点。默认将其关闭是刻意的:模型元数据 > 写入 也是代理通过 MCP 服务器所需的权限,因此在 MCP 服务器端授予该权限时,不应悄然改变聊天能做什么。参见 允许助手更改你的模型。
预览更改(已启用)
在助手所做的更改生效前显示脚本预览对话框,以便你查看每一项模型元数据更改,并选择接受或取消。取消会将模型恢复原状,并告知助手你已拒绝该更改。
AI 功能 > MCP 服务器
MCP 服务器的设置。它允许 Claude Code、GitHub Copilot 或 Cursor 等外部代理处理你当前打开的模型。

启用 MCP 服务器(已启用)
用于控制 MCP 服务器是否启用。取消选中后,会停止正在运行的服务器,并移除 工具 > MCP 服务器... 菜单项和状态栏指示器。
自动启动 MCP 服务器(已禁用)
在 Tabular Editor 启动时启动服务器,这样代理无需你手动启动即可连接。如果启动时该端口已被占用,服务器不会启动,也不会显示提示。
要求访问令牌(已禁用)
要求代理提供 Bearer 令牌,该令牌会显示在 工具 > MCP 服务器... 对话框中。服务器仅侦听回环接口,因此这在多名用户同时登录的计算机上尤为重要,例如远程桌面或 Citrix 主机,因为每个会话都可以访问 127.0.0.1。管理员可通过 RequireMcpAccessToken 策略 强制启用此项。
端口(42100)
服务器侦听的回环端口,范围为 1024 到 49151。更改端口会使现有代理注册失效,因为它们指向的是固定地址。如果你手动启动服务器时该端口已被占用,Tabular Editor 会提供它找到的下一个可用端口。
AI 功能 > 权限
每个资源对应一项常设授权,同时适用于 AI Assistant 聊天以及通过 MCP 服务器连接的任何代理。聊天还可以额外请求授权未涵盖的内容;代理则不能。因此对于 MCP,授权将按现状生效,只有在服务器重启时才会更新。

| 资源 | 级别 | 默认值 | 涵盖范围 |
|---|---|---|---|
| 模型元数据 | 拒绝 / 读取 / 写入 | 读取 | 表、列、度量值、表达式、描述和关系,以及 VertiPaq分析器的统计信息。写入权限允许通过 C# Script 进行更改 |
| 模型数据 | 拒绝 / 读取 | 拒绝 | 来自模型的数据值,例如 DAX 查询结果。不提供写入级别 |
| Best Practice Analyzer | 拒绝 / 读取 / 写入 | 读取 | 读取会列出规则并运行分析;写入可添加或修改规则 |
| 文档 | 拒绝 / 读取 / 写入 | 写入 | 你当前打开的 C# Script 和 DAX 查询标签页。读取用于查看其内容;写入用于创建或修改它们 |
| 宏 | 拒绝 / 读取 / 写入 | 写入 | 你的宏库 |
写入 已包含读取权限,因此无需同时授予两者。模型数据是默认被拒绝的唯一资源,因为元数据描述的是你的模型,而数据_本身_就是它的内容。
在 Enterprise、Consultancy 和 Trial 版本中,管理员可以通过策略为其中任意一项设置上限,并可分别对聊天和 MCP 服务器单独设定。被设定上限的下拉框会显示为只读。关于聊天如何请求授权未涵盖的内容,见 @ai-assistant;关于代理能看到什么,见 @mcp-server。
Tabular Editor > 杂项

元数据同步
这些设置控制 Tabular Editor 3 如何处理在应用程序外部发生变化的模型元数据。前三项适用于从 Analysis Services 实例上的数据库加载的模型,并且都依赖 Analysis Services 跟踪。自动从磁盘重新加载 适用于从文件或文件夹加载的模型,并会直接监视这些文件。
当本地元数据与已部署模型不同步时发出警告(已启用)
勾选后,只要你对模型进行了尚未保存到 Analysis Services 的本地更改,Tabular Editor 内就会显示一条信息栏。例如,如果你想知道为什么 DAX 查询或 Pivot Grid 没有得到预期结果,可能是因为你在 Tabular Editor 中更改了某个度量值表达式,但尚未将更改保存到 Analysis Services。保存(Ctrl+S)后,该提示栏就会消失。
跟踪外部模型更改(已启用)
就像 Power BI Desktop 能检测到外部工具对 Data model 做出的更改一样,Tabular Editor 也能做到。此选项仅适用于 Analysis Services 的本地实例(即与 Tabular Editor 运行在同一台计算机上的 msmdsrv.exe 进程)。选中后,Tabular Editor 会在 Analysis Services 上启动跟踪,并在发生外部更改时通知你。
自动刷新本地 Tabular Object Model 元数据(已启用)
启用上述跟踪机制后,勾选这个选项即可让 Tabular Editor 在检测到外部更改时自动刷新模型元数据。如果你经常在 Power BI Desktop 和 Tabular Editor 3 之间来回切换,这会很有用。
自动从磁盘重新加载(已启用)
选中后,Tabular Editor 会监视模型加载来源的元数据文件,并在其他应用程序更改这些文件时重新加载模型。与上面两个设置不同,这项设置不涉及 Analysis Services 跟踪:它直接监视文件本身,因此适用于从 .bim 文件或文件夹加载的模型,无论是否涉及服务器。如果模型有未保存的更改,Tabular Editor 会询问你要保留哪个副本。见自动从磁盘重新加载。
清理遗留的 Tabular Editor 跟踪
通常,Tabular Editor 3 会自动停止并移除因上述设置而启动的所有 AS 跟踪。但是,如果应用程序异常退出,这些跟踪可能永远不会停止。点击此按钮后,将移除由任何 Tabular Editor 实例启动的所有 AS 跟踪。
Note
清理按钮只有在 Tabular Editor 连接到 Analysis Services 实例时才可用。
数据浏览 > Pivot Grid

基本
自动刷新 Pivot Grid (已启用)
保存模型更改后,自动刷新 Pivot Grid。与 DAX 查询一样,这能让你立即看到度量值更改带来的影响。
Pivot Grid 字段不匹配时发出警告(已启用)
当 Pivot Grid 的字段定义与当前模型不匹配时显示警告。如果你删除或重命名了已保存的 Pivot Grid 中使用的字段,就可能发生这种情况。
字段标题
Pivot 表头自动换行(已启用)
在 Pivot Grid 标题中启用自动换行。这会让较长的字段名称更易阅读。
字段列表
始终显示 Pivot Grid 字段列表(已启用)
默认保持 Pivot Grid 字段列表可见。如果你希望为 Pivot Grid 本身腾出更多屏幕空间,可禁用此选项。
在透视表自定义中显示所有字段(已启用)
默认在 Pivot Grid 字段列表中显示所有可用字段,包括隐藏字段。
Pivot Grid 自定义默认布局 (StackedDefault)
选择 Pivot Grid 字段列表的默认布局。可选项包括:
- StackedDefault:字段和区域显示在同一个堆叠面板中
- StackedSideBySide:字段和区域显示在并排面板中
- TopPanelOnly:字段列表仅在顶部显示
- BottomPanelOnly2by2: 底部以 2x2 网格显示字段列表
- BottomPanelOnly1by4:底部 1x4 布局的字段列表
数据浏览 > DAX 查询

基本
默认自动执行 DAX 查询(已启用)
新建的 DAX 查询会默认启用 自动执行,因此每当已部署的语义模型发生更改时,查询都会重新运行。如果你更希望手动执行每个查询,就将其关闭。
在结果网格中保留现有排序和筛选(WhenQueryUnchanged)
控制重新执行查询时是否保留网格筛选和排序:
- Never:每次执行查询都会重置排序和筛选
- WhenQueryUnchanged:仅在查询被修改时才会重置排序和筛选
- Always:只要列仍然存在,就不会重置排序和筛选
查询设置
智能选择(已启用)
当你执行查询中的一部分时,Tabular Editor 会替你将该选区转换为有效的 DAX 查询:把标量表达式用大括号括起来,并在所选内容中未包含 DEFINE 部分或 EVALUATE 关键字时自动补上它们。
行数限制(1,000)
会将每个 EVALUATE 语句包装在 TOPN 调用中,避免误对大型表执行查询时运行过久或耗尽内存。将其设为 0 即可完全取消限制。
代码生成
使用注释作为分隔符(已启用)
在生成的对象定义中插入注释,例如 在查询中定义对象 生成的 DEFINE 块,以便更易阅读。
数据浏览 > 表格预览

基本
默认自动刷新表格预览(已启用)
新打开的表格预览会默认启用 自动刷新,因此每当对已部署的语义模型进行更改时,预览都会刷新。这在调试时很有用:可以在一个窗口中更新表达式,同时在另一个窗口中打开同一张表的预览。
按字母顺序对表格预览列排序(已禁用)
选中后,表格预览中的列会按名称的字母顺序排序,并与 TOM Explorer 视图 中列出的表列顺序一致。未选中时(默认),列会按引擎返回的顺序显示,这大致对应内部列顺序,看起来可能比较随意。
最大。筛选器下拉列表中的值 (5,000)
列的筛选下拉列表中列出的不同值的最大数量。如果某列的不同值数量超过此限制,超出限制的值将不会列出,也无法直接勾选。提高此值可以显示更多值,但每次打开下拉列表时都需要执行开销更大的查询。可设置范围为 100 到 1,000,000。
最大。行数(100,000)
Tabular Editor 按没有属性层次结构的列进行排序时,可排序的最大行数。
DirectQuery
行数限制(100)
DirectQuery 模式下,表格预览可检索的最大行数。如果你需要查看更多数据,可以提高该值,但请记住每一行数据都需要从底层数据源中提取。
行为
在 TOM Explorer 中跟踪所选列(已启用)
当你在 TOM Explorer 视图 中选择某一列时,已打开的表格预览会自动滚动到该列并将其高亮显示,这是在超宽表中定位某一列最快的方法。也可以在表格预览工具栏中通过 跟踪所选列,针对单个预览启用或禁用此设置。
DAX编辑器 > 常规

Tabular Editor 3 的 DAX编辑器可高度自定义。这个页面提供 DAX编辑器的常规设置:
行号(已启用)
在编辑器左侧边距显示行号。
代码折叠(已启用)
在 DAX 代码中启用可折叠区域,以提升可读性。一定要试试这个功能!
显示空白字符(已禁用)
将空格显示为圆点,将制表符显示为箭头。这有助于诊断缩进问题。
缩进引导线(已启用)
显示竖线以标示缩进层级。
使用制表符(已禁用)
选中后,每次按下 TAB 键时都会插入一个制表符 (\t)。否则,会插入与 缩进宽度 设置对应数量的空格。
注释样式(斜杠)
DAX 支持使用斜杠(//)或连字符(--)的行注释。此设置决定 Tabular Editor 3 生成 DAX 代码时使用哪种注释样式。
DAX 函数文档
使用此设置指定:当光标位于某个 DAX 函数上并按下 F12 时,默认浏览器要打开的 URL。可选项包括 https://dax.guide(推荐)和 Microsoft 官方文档。
DAX 设置
区域设置
设置 DAX 函数和格式所使用的区域设置。
Analysis Services 版本设置
只有当 Tabular Editor 3 无法确定所使用的 Analysis Services 版本时,这些设置才会用得上,比如直接加载 Model.bim 文件时就是这样。在这种情况下,Tabular Editor 会根据兼容级别推测模型将部署到的版本。如果 Tabular Editor 的 Report 误报语义或语法错误,你可能需要调整这些设置。
DAX编辑器 > 自动格式化

DAX编辑器 非常 强大,能在你输入的同时帮你写出漂亮、易读的 DAX 代码。
输入时自动格式化代码(已启用)
这个选项会在发生某些按键操作时,自动应用特定的格式规则。例如,当输入右括号时,此功能会确保括号内的所有内容都按本页中的其他设置进行格式化。
自动格式化函数调用(已启用)
此选项专门控制:当输入右括号时,是否对函数调用(参数与括号之间的空格)进行自动格式化。
自动缩进(已启用)
这个选项会在函数调用内插入换行时,自动缩进函数参数。
自动补全括号(已启用)
当输入左括号或引号时,此选项会自动插入对应的右括号或引号。
包裹选中内容(已启用)
启用后,当输入开括号时,此选项会自动用对应的闭括号包裹当前选中内容。
格式化规则
这些设置用于控制 DAX 代码中空白字符的格式:既包括自动格式化时的处理,也包括手动格式化代码时的处理。
函数后加空格(已禁用)
函数后换行(已禁用)
仅在函数调用需要拆分为多行时生效。
括号内补空格(已启用)
长格式行长度限制(120)
在使用 格式化 DAX(长行) 选项时,表达式在被拆分为多行之前,单行可保留的最大字符数。
短格式行长度限制(60)
使用 Format DAX (short lines) 选项时,表达式在拆分为多行之前,每行最多保留的字符数。
大小写和引号
除了格式化 DAX 代码的空白字符外,Tabular Editor 3 还可以修正对象引用,以及函数/关键字的大小写。
修正度量值/列限定符(已启用)
选中后,会自动从度量值引用中移除表前缀,并在列引用中自动插入表前缀。
首选关键字大小写(UPPER)
此设置可让你更改关键字的大小写形式,例如 ORDER BY、VAR、EVALUATE 等。它还会影响自动补全为接受这些固定关键字 值 的函数所提供的关键字形式:ASC 和 DESC、KEEP、FIRST、LAST 和 DEFAULT、CROSSFILTER 的方向,以及 LOOKUP 的 EXPLICIT 和 INFERRED。选择 仅首字母大写 后,自动补全会提供 Explicit 而不是 EXPLICIT。
首选函数大小写(UPPER)
此设置可让你更改函数名称的大小写形式,例如 CALCULATE(...)、SUM(...) 等。
修正关键字/函数大小写(已启用)
选中后,无论是自动格式化还是手动格式化代码,都会自动更正关键字和函数的大小写。
修正对象引用大小写(已启用)
DAX 是一种不区分大小写的语言。启用后,对表、列和度量值的引用会自动更正大小写,使其与所引用对象的实际名称一致。
始终为表名加引号(已禁用)
在 DAX 中,引用某些表名时不需要用单引号括起来。不过,如果你希望表引用始终带引号,可以勾选此选项。
扩展列始终加前缀(已禁用)
扩展列可以在不带表名的情况下定义。选中后,DAX编辑器将始终为扩展列添加表前缀。
DAX编辑器 > Code Assist

在此页面上,你可以配置两项最重要的 Code Assist 功能:调用提示(也称“参数信息”)和自动完成。
自动完成触发方式
控制自动补全列表何时出现。可选项包括:在输入一定数量的字符后自动触发,或通过 CTRL+Space 手动触发。
参数提示触发
控制参数信息何时显示。可选项包括:在输入函数左括号时自动触发,或手动触发。
增量搜索(已启用)
在自动补全中启用模糊/增量搜索。这样你就可以通过输入名称的一部分来查找条目,而不仅限于名称开头。
建议表名(已启用)
在自动完成建议中包含表名。
始终为表名加引号(已禁用)
在建议中自动为表名加引号,即使并非必需。
仅显示首字母(已禁用)
仅显示以输入字母开头的条目。禁用此项可改用增量搜索。
DAX编辑器 > 代码操作

配置自动代码改进建议:
变量前缀
定义变量名可接受的前缀(例如 _、__、var_、var、v_、v、VAR_)。代码操作会建议为不符合约定的变量名添加这些前缀。
列前缀
定义临时列名可接受的前缀(例如 @、_、x、x_)。代码操作会建议为不符合约定的临时列名添加这些前缀。
SQL 编辑器 / M 编辑器 / C# 编辑器
SQL、M(Power Query)和 C# Script 编辑器也提供类似的配置选项,包括:
- 语法高亮和配色方案
- 自动格式化选项
- Code Assist 和自动完成功能
- 注释样式和缩进偏好
每个编辑器都可以单独自定义,以符合你偏好的代码风格。
DAX Formatter
DAX formatter 同意(已禁用)
同意将 DAX 代码发送到外部 DAX 格式化服务 (www.daxformatter.com)。启用后,你可以使用此服务按社区标准格式化 DAX 代码。
DAX formatter 请求超时(5000)
DAX formatter 请求的超时时间,单位为毫秒。如果使用 DAX Formatter 时经常遇到超时错误,请增大此值。
DAX优化器集成
配置 DAX优化器集成(仅企业版):
自动连接(null/提示)
在可用时自动连接到 DAX优化器。未设置时,系统会在首次使用时提示你。
对 VPAX 文件进行混淆处理(已启用)
发送到 DAX优化器时对模型元数据进行匿名化处理。这可以保护表名和列名等敏感信息,同时仍允许进行分析。
混淆字典目录(%LocalAppData%\TabularEditor3\DaxOptimizer)
指定混淆字典的存储位置。该字典可在多次分析之间保持一致的混淆结果。
VertiPaq分析器

包含 TOM 元数据(已启用)
在 VertiPaq分析器的统计信息中包含 Tabular Object Model 元数据。这将提供有关模型结构的更丰富信息。
从数据读取统计信息(已启用)
通过扫描实际数据来读取统计信息(更准确,但更慢)。禁用后,仅使用元数据。
Direct Lake 提取模式(ResidentOnly)
如何从 Direct Lake 模型中提取统计信息:
- ResidentOnly:仅分析当前已加载到内存中的数据
- All:包含未驻留的数据(更慢,可能触发数据加载)
从动态管理视图读取统计信息(已禁用)
使用 DMV 收集统计信息(更快,但准确性较低)。这是从数据读取的替代方案。
关系采样行数(3)
分析关系时要采样的行数。值越高,准确性越高,但耗时也越长。
列批次大小(50)
每个批次中要分析的列数。请根据模型大小和性能要求调整此项。
Power BI 集成

Power BI 端点基础 URL(https://api.powerbi.com)
用于 Power BI API 调用的基础 URL。如果你在主权云或自定义环境中工作,请更改此设置。
Fabric 端点基础 URL(https://api.fabric.microsoft.com)
用于调用 Microsoft Fabric API 的基础 URL。如果你在主权云或自定义环境中工作,请更改此设置。
使用嵌入式浏览器进行身份验证(已启用)
使用嵌入式浏览器进行 OAuth 身份验证,而不是系统浏览器。这将提供更集成的体验。
代理设置

代理类型(无)
可在以下选项中选择:
- 无:不配置代理
- 系统:使用系统代理设置
- 自定义:指定自定义代理配置
代理地址
代理服务器的地址(例如 http://proxy.company.com:8080)。
代理用户
如需代理身份验证,请输入用户名。
代理密码
用于代理身份验证的密码(加密存储)。
使用默认凭据(已启用)
使用当前的 Windows 凭据进行代理身份验证。其行为与 Power BI Desktop 一致。
对本地地址绕过代理(已启用)
对本地地址绕过代理。出于性能考虑,建议使用此选项。
代理绕过列表
应绕过代理的地址列表(例如 localhost;*.company.local)。
后续步骤
如需查看有关最常调整的偏好设置的易用指南,请参阅入门指南 Personalizing TE3。